[ Fixed ] Blacksn0w Can Unlock iPhone 3.1.3 With Baseband 05.11.07

Yes Blacksn0w can now unlock both iphone 3g and 3gs with firmware 3.1.3 with 05.11.07 baseband, a guy named msft.guy has found fix for blacksn0w to unlock iPhone 3.1.3 Baseband 05.11.07


The main reason because it searches for the function to patch by searching the binary for a reference to string “SIM is not supported”. In 3.1.3 the same function now uses the string "Verified" in the reverse condition branch. Since the location to patch is determined by instruction search&replace, the patch itself still works in 3.1.3 after changing the string and its length in Blacksn0w binary.

DISCLAIMER: This fix only tested on 3GS, please test-run before installing permanently; failure to do so or installing original BlackSn0w on 3.1.3 will force you to restore!

You can read the full fix on our iphone news blog

Leave a Reply

Your email address will not be published. Required fields are marked *